CVE-2019-11190 – The Linux kernel before 4.8 allows local users to bypass ASLR on setuid programs (such as …

Vuln ID: CVE-2019-11190

Published:  2019-04-12  00:29:00Z

Description: The Linux kernel before 4.8 allows local users to bypass ASLR on setuid programs (such as /bin/su) because install_exec_creds() is called too late in load_elf_binary() in fs/binfmt_elf.c, and thus the ptrace_may_access() check has a race condition when reading /proc/pid/stat.

Source: NVD.NIST.GOV

 

Tags