CVE-2018-18628 – An issue was discovered in Pippo 1.11.0. The function SerializationSessionDataTranscoder.d …

0

Vuln ID: CVE-2018-18628

Published:  2018-10-23  20:29:00Z

Description: An issue was discovered in Pippo 1.11.0. The function SerializationSessionDataTranscoder.decode() calls ObjectInputStream.readObject() to deserialize a SessionData object without checking the object types. An attacker can create a malicious object, base64 encode it, and place it in the PIPPO_SESSION field of a cookie. Sending this cookie may lead to remote code execution.

Source: NVD.NIST.GOV