CVE-2018-9230 – ** DISPUTED ** In OpenResty through 1.13.6.1, URI parameters are obtained using the ngx.re …

0

Vuln ID: CVE-2018-9230 (openresty)

Published:  2018-04-02  18:29:00Z

Description: ** DISPUTED ** In OpenResty through 1.13.6.1, URI parameters are obtained using the ngx.req.get_uri_args and ngx.req.get_post_args functions that ignore parameters beyond the hundredth one, which might allow remote attackers to bypass intended access restrictions or interfere with certain Web Application Firewall (ngx_lua_waf or X-WAF) products. NOTE: the vendor has reported that 100 parameters is an intentional default setting, but is adjustable within the API. The vendor’s position is that a security-relevant misuse of the API by a WAF product is a vulnerability in the WAF product, not a vulnerability in OpenResty.

Source: NVD.NIST.GOV