CVE-2018-7206 – An issue was discovered in Project Jupyter JupyterHub OAuthenticator 0.6.x before 0.6.2 an …

0

Vuln ID: CVE-2018-7206

Published: 2018-02-18  03:29:00Z

Description: An issue was discovered in Project Jupyter JupyterHub OAuthenticator 0.6.x before 0.6.2 and 0.7.x before 0.7.3. When using JupyterHub with GitLab group whitelisting for access control, group membership was not checked correctly, allowing members not in the whitelisted groups to create accounts on the Hub. (Users were not allowed to access other users’ accounts, but could create their own accounts on the Hub linked to their GitLab account. GitLab authentication not using gitlab_group_whitelist is unaffected. No other Authenticators are affected.)

Source: NVD.NIST.GOV