CVE-2017-3158 – A race condition in Guacamole’s terminal emulator in versions 0.9.5 through 0.9.10-incubat …

0

Vuln ID: CVE-2017-3158

Published: 2018-01-18  20:29:00Z

Description: A race condition in Guacamole’s terminal emulator in versions 0.9.5 through 0.9.10-incubating could allow writes of blocks of printed data to overlap. Such overlapping writes could cause packet data to be misread as the packet length, resulting in the remaining data being written beyond the end of a statically-allocated buffer.

Source: NVD.NIST.GOV